If SmartScraperGraph throws a pydantic ValidationError on 1.14.0 or newer, do not downgrade to pre-1.14 - install a beta containing the fix (1.19.0-beta10 or newer, beta11 confirmed working). Note the version trap from the thread: 1.19.0 final is older than 1.19.0-beta11 in fix terms, so check that your installed version actually includes the merged fix rather than assuming a higher-looking number is newer.

Context: Issue ScrapeGraphAI/Scrapegraph-ai#598 (closed, 62 comments): starting with version 1.14.0, SmartScraperGraph on OpenAI broke with a pydantic ValidationError. Reporters confirmed the fix landed in the beta line - 1.19.0-beta10 merged the fix and 1.19.0-beta11 resolved it, while the plain 1.19.0 release still had the bug.

## Matched source
Source: Published skill
Original query: "pydantic ValidationError on 1.14.0+ - install a beta with the fix, not 1.19.0 final"
Key terms: beta, final, install, pydantic, validationerror
