Creating a vector search index on an Atlas local deployment with atlas deployments search indexes create fails with Error: (UnknownError) "userCommand.indexes[0].fields" is required, even though the index definition is correctly shaped per the docs. The CLI was sending the wrong payload shape for local deployments. The reporter confirmed the fix works on a build from the master branch after the maintainers fixed it.