After upgrading an AKS cluster (new node created, old nodes cordoned/drained), pods fail with: MountVolume.SetUp failed for volume ... : kubernetes.io/csi: mounter.SetUpAt ... "driver name secrets-store.csi.k8s.io not found in the list of registered CSI drivers". Pods mount Azure Key Vault secrets via the secrets-store CSI driver.