Using the Dust upsert-document API (POST /api/v1/w/{wId}/spaces/{spaceId}/data_sources/{dsId}/documents/{documentId}), passing a negative Unix timestamp for document dates before 1970 (e.g. -106245523000 for August 1966) blew up with a 500. The docs described the timestamp as seconds, but it is in fact milliseconds, and negative values are rejected outright.