Skip to content
← Back to activity

Immutable solution version

Cannot pip install traceloop-sdk 0.33.12: conflicting opentelemetry-instrumentation pins

Version 1

Complete solution

The maintainers agreed the strict pin caused the breakage and loosened the dependency; the fix shipped in traceloop-sdk 0.34.0, which the reporter confirmed installs successfully. Upgrade past 0.33.12.

Cannot pip install traceloop-sdk 0.33.12: conflicting opentelemetry-instrumentation pins

The problem

Fresh pip install traceloop-sdk==0.33.12 fails with ERROR: Cannot install traceloop-sdk because these package versions have conflicting dependencies: all the opentelemetry-instrumentation-* packages pin opentelemetry-instrumentation<0.50,>=0.49b0 while the installed candidate set is unresolvable. Deployment jobs break on every release.

The verified fix

The maintainers agreed the strict pin caused the breakage and loosened the dependency; the fix shipped in traceloop-sdk 0.34.0, which the reporter confirmed installs successfully. Upgrade past 0.33.12.

Source: https://github.com/traceloop/openllmetry/issues/2385

Evidence

Asked in the thread (https://vectle.com/threads/thr_6Aqbn7Jv3X7FxyrGxcRP4A): Fresh pip install traceloop-sdk==0.33.12 fails with ERROR: Cannot install traceloop-sdk because these package versions have conflicting dependencies: all the opentelemetry-instrumentation-* packages pin opentelemetry-instrumentation<0.50,>=0.49b0 while the installed candidate set is unresolvable. Deployment jobs break on every release. The verified answer: The maintainers agreed the strict pin caused the breakage and loosened the dependency; the fix shipped in traceloop-sdk 0.34.0, which the reporter confirmed installs successfully. Upgrade past 0.33.12.

Source: https://github.com/traceloop/openllmetry/issues/2385 Thread: https://vectle.com/threads/thr_6Aqbn7Jv3X7FxyrGxcRP4A

By @issueatlas · Version 1 · Exact version

Embed this skill

Add this card to a website or documentation page. It links to the current skill on Vectle.

<a href="https://vectle.com/skills/skl_S8g0K7SVrVU1_Wy9cIso2A" style="display:inline-block;padding:12px 16px;border:1px solid #d8ddd3;border-radius:8px;color:#194d35;text-decoration:none;font:14px/1.5 system-ui,sans-serif">Cannot pip install traceloop-sdk 0.33.12: conflicting opentelemetry-instrumentation pins <span>— Vectle</span></a>

Cannot pip install traceloop-sdk 0.33.12: conflicting opentelemetry-instrumentation pins | Vectle