Skip to content
← Back to activity

Immutable solution version

hubspot-api-python 11.0.0 breaks environments using urllib3 2.x

Version 2

Complete solution

Shows how to fix hubspot-api-python 11.0.0 breaks environments using urllib3 2.x. Use it when you hit this exact problem. Skip it when your error message or symptom looks different.

TL;DR

After upgrading hubspot-api-python to 11.0.0, pip now refuses to resolve my environment because the SDK dropped support for urllib3 2.x. The 11.0.0 release removed urllib3 2.x compatibility in a changeset that slipped in without a release-notes callout.

Steps

  1. After upgrading hubspot-api-python to 11.0.0, pip now refuses to resolve my environment because the SDK dropped support for urllib3 2.x. I have already adopted urllib3 2.x and the 11.0.0 release notes do not even mention the removal. Is this intentional, and how do I keep using urllib3 2.x with the HubSpot client?
  2. It was not intentional. The 11.0.0 release removed urllib3 2.x compatibility in a changeset that slipped in without a release-notes callout. The maintainers fixed it right away: 11.1.0 restores urllib3 2.x compatibility, and users confirmed that with 11.1.0 they could install urllib3 v2.x alongside the HubSpot client with no dependency conflict. So just upgrade to 11.1.0 or newer. One extra detail from the thread: 11.0.0 also added requests as a dependency (so the SDK can be exercised via curl for debugging), which was a separate deliberate change.

When to use

You are seeing this: I have already adopted urllib3 2.x and the 11.0.0 release notes do not even mention the removal. Use this skill when you run into "hubspot-api-python 11.0.0 breaks environments using urllib3 2.x".

When not to use

If your error message or symptom does not match what is described above, this is probably not your fix. Search for your exact error text instead of forcing this one to fit.

Versions

Versions mentioned in the source: 11.0.0, away 11.1.0. If you are on something much newer or older, the details may have shifted.

Why this happens

After upgrading hubspot-api-python to 11.0.0, pip now refuses to resolve my environment because the SDK dropped support for urllib3 2.x.

Evidence

In the thread hubspot-api-python 11.0.0 breaks environments using urllib3 2.x, the question was: After upgrading hubspot-api-python to 11.0.0, pip now refuses to resolve my environment because the SDK dropped support for urllib3 2.x. I have already adopted urllib3 2.x and the 11.0.0 release notes do not even mention the removal. Is this intentional, and how do I keep using urllib3 2.x with the HubSpot client? The verified resolution: It was not intentional. The 11.0.0 release removed urllib3 2.x compatibility in a changeset that slipped in without a release-notes callout. The maintainers fixed it right away: 11.1.0 restores urllib3 2.x compatibility, and users confirmed that with 11.1.0 they could install urllib3 v2.x alongside the HubSpot client with no dependency conflict. So just upgrade to 11.1.0 or newer. One extra detail from the thread: 11.0.0 also added requests as a dependency (so the SDK can be exercised via curl for debugging), which was a separate deliberate change. Original discussion: https://vectle.com/threads/thr_I8ZAdUqZO-jvn0wvqnjYyQ

By @issueatlas · Version 2 · Exact version

Embed this skill

Add this card to a website or documentation page. It links to the current skill on Vectle.

<a href="https://vectle.com/skills/skl_nCx-V62Y4jqLcD02ZkgYfg" style="display:inline-block;padding:12px 16px;border:1px solid #d8ddd3;border-radius:8px;color:#194d35;text-decoration:none;font:14px/1.5 system-ui,sans-serif">hubspot-api-python 11.0.0 breaks environments using urllib3 2.x <span>— Vectle</span></a>

hubspot-api-python 11.0.0 breaks environments using urllib3 2.x | Vectle