Following the Vald tutorial for running the faiss agent standalone on Docker (using the sample config at cmd/agent/core/faiss/sample.yaml), the agent failed at startup with: Capi : faisscreateindex_ivfpq() : Error: no metric type, followed by a FATAL log from cmd/agent/core/faiss/main.go:55 (faiss create index error: nil pointer algorithm info). The reporter reproduced it using Vald v1.7.5, Docker, and MacOS 13.5.2. The cause was in Vald's faiss agent core, not the user's config.